Oddlabs Forum

It is currently Fri Jul 25, 2014 9:35 pm

All times are UTC + 1 hour




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 12 posts ] 
Author Message
 Post subject: Universal Binary problems
PostPosted: Thu Mar 09, 2006 10:14 pm 
Offline

Joined: Thu Mar 09, 2006 9:57 pm
Posts: 4
I just downloaded the Mac version of TribalTrouble, which should be a UB.
But it seems not to be (at least the Finder says it's PowerPC only).

A few seconds after starting it, the loading screen comes up in full screen and then it crashes. No error message or something, everything is just gone. Not even the standard crash-widow (Reopen, Report...) comes up.

Starting it from the Terminal I get the following messages:
Code:
[JavaAppLauncher] application launched with ppc-thin application stub. Using native application stub instead.
LOADER: Starting from directory gamedata/data-1
Starting game....
********** Running tt **********
Writing log files in /Applications/TribalTrouble/Tribal Trouble.app/Contents/Resources/Java/logs/1141938545813
Could not locate symbol glLoadProgramNV
Invalid memory access of location 222ff000 eip=ffff0840
Segmentation fault


The logs can be viewed here:
http://www.qoconut.com/logs/event.log
http://www.qoconut.com/logs/std.err
http://www.qoconut.com/logs/std.out

I'm running a Mac mini Core Duo 1.67 GHz 512 MB Ram

Thanks in advance!


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 10, 2006 12:12 pm 
Offline
Administrator
User avatar

Joined: Fri Sep 26, 2003 6:45 pm
Posts: 26
We will have to wait for our own Mac mini to arrive.
Till then you can try to find and send us all your JavaNativeCrash* files located in /Users/USER/Library/Logs/Java/

Mikkel


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 10, 2006 4:23 pm 
Offline

Joined: Thu Mar 09, 2006 9:57 pm
Posts: 4
Here's another log: http://www.qoconut.com/logs/JavaNativeCrash.crash.log


Top
 Profile  
 
 Post subject: Same with me..
PostPosted: Sat Mar 18, 2006 8:54 am 
Offline

Joined: Sat Mar 18, 2006 8:51 am
Posts: 2
Location: Bay Area, CA
I get the exact same problem. Running the same hardware.

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 21, 2006 9:57 pm 
Offline
User avatar

Joined: Fri Sep 26, 2003 6:34 pm
Posts: 71
Our new Intel Mac Mini finally arrived (this is one impressive piece of hardware!), now we just need our programmers back from the Game Developers Conference :)
With a little luck we'll have Tribal Trouble up and running on the Mini first thing next week.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 21, 2006 10:45 pm 
Offline

Joined: Thu Mar 09, 2006 9:57 pm
Posts: 4
Great, thanks! :)


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 28, 2006 8:28 pm 
Offline

Joined: Tue Mar 28, 2006 8:27 pm
Posts: 2
Location: USA
jacob wrote:
Our new Intel Mac Mini finally arrived (this is one impressive piece of hardware!), now we just need our programmers back from the Game Developers Conference :)
With a little luck we'll have Tribal Trouble up and running on the Mini first thing next week.


Good news! Yes, it is a great little machine. Have they had a chance to check it out at all? I hope it is something simple to fix.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 28, 2006 8:37 pm 
Offline
User avatar

Joined: Fri Sep 26, 2003 6:34 pm
Posts: 71
Well, right now the poor fellows are suffering from jetlag after getting back last night :)

I think they'll have a look at it tomorrow, hopefully it's just a simple OpenGL issue with the video card drivers that can be worked around.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 31, 2006 1:22 pm 
Offline
Administrator
User avatar

Joined: Fri Sep 26, 2003 6:44 pm
Posts: 1208
The problem has been fixed. It was an error in their drivers as suspected, and we had to work around it.

- Sune


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 31, 2006 1:26 pm 
Offline

Joined: Thu Mar 09, 2006 9:57 pm
Posts: 4
That's good news!

edit:
I just wanted to add that it works absolutely perfect on my Mac mini Intel Core Duo, now.
Thanks!


Top
 Profile  
 
 Post subject: WOOOHOOOO!!
PostPosted: Fri Mar 31, 2006 5:09 pm 
Offline

Joined: Sat Mar 18, 2006 8:51 am
Posts: 2
Location: Bay Area, CA
Works great now on my Mac Mini. Yay.

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 31, 2006 5:23 pm 
Offline

Joined: Tue Mar 28, 2006 8:27 pm
Posts: 2
Location: USA
Works! Thanks!


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 12 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group